آموزش تغییر ویرایشگر گوتنبرگ به ویرایشگر کلاسیک وردپرس

ویرایشگر کلاسیک وردپرس
ویرایشگر کلاسیک وردپرس

پس از نصب و راه‌اندازی وردپرس، لازم است برای طراحی وبسایت وردپرسی خود با ویرایشگرهای این سیستم مدیریت محتوای محبوب آشنا شوید، نخستین ویرایشگر پیشفرض وردپرس، ویرایشگر کلاسیک بوده است که با نصب وردپرس، ویرایشگر کلاسیک نیز به طور خودکار همراه با آن قابل استفاده بوده و کاربران طی چندین سال از ویرایشگر کلاسیک به منظور نوشتن و انتشار مطالب خود استفاده می‌کردند. با روی کار آمدن نسخه 5 وردپرس، یک ویرایشگر جدید به نام ویرایشگر گوتنبرگ نیز به آن اضافه شد که از آن پس به عنوان ویرایشگر پیشفرض سیستم مدیریت محتوای وردپرس شناخته می‌شود. گوتنبرگ دارای امکانات پیشرفته‌ای نیز می‌باشد اما برخی از کاربران نیاز دارند در کنار استفاده از نسخه جدید وردپرس بتوانند از ویرایشگر قدیمی کلاسیک استفاده کنند. اگر شما نیز از طرفداران استفاده از ادیتور کلاسیک هستید تا انتهای این مقاله با ما همراه باشید تا نحوه تغییر ادیتور گوتنبرگ به کلاسیک در وردپرس را به شما آموزش دهیم.

ویرایشگر کلاسیک وردپرس

آنچه در این مقاله به اختصار خواهید خواند:

  • ویرایشگر کلاسیک وردپرس چیست؟
  • استفاده از ویرایشگر کلاسیک وردپرس با افزونه Classic Editor
  • ایجاد نوشته و برگه با ویرایشگر کلاسیک

ویرایشگر کلاسیک وردپرس چیست؟

ادیتورهای وردپرس از امکانات جذاب و البته ضروری برای مدیریت وبسایت، نوشتن، طراحی و انتشار مطالب می‌باشد. پس از گذشت سال‌ها و از زمان انتشار نسخه‌ی 5 وردپرس، ادیتور گوتنبرگ به عنوان ویرایشگر پیشفرض معرفی شد، اما در صورت تمایل می‌توانید ادیتور خود را تغییر داده و از ویرایشگر کلاسیک در وردپرس استفاده کنید. ادیتور گوتنبرگ با اینکه دارای امکانات و قابلیت‌های بسیار زیادی می‌باشد اما برخی از کاربران همچنان تمایل به استفاده از ویرایشگر کلاسیک برای طراحی و مدیریت سایت وردپرسی خود دارند، به همین دلیل در ادامه این مقاله افزونه‌ای را به شما معرفی می‌کنیم تا به آسانی بتوانید به تغییر ادیتور گوتنبرگ به کلاسیک در وردپرس اقدام نمایید.

در صورتی که به تازگی با سیستم مدیریت محتوای وردپرس آشنا شده‌اید توصیه می‌کنیم ابتدا قبل از مطالعه این مقاله، سرفصل‌های آموزش وردپرس را مطالعه کرده، سپس با ما همراه باشید تا چگونگی تغییر ادیتور گوتنبرگ به کلاسیک در وردپرس را به شما آموزش دهیم. برای مشاهده سرفصل‌های آموزش وردپرس اینجا کلیک کنید.

استفاده از ویرایشگر کلاسیک وردپرس با افزونه Classic Editor

آیکون افزونه ویرایشگر کلاسیک
آیکون افزونه ویرایشگر کلاسیک

برای تغییر ادیتور گوتنبرگ به کلاسیک در وردپرس می‌توان از افزونه استفاده کرد، افزونه Classic Editor با بیش از 5 میلیون نصب فعال به شما کمک می‌کند تا به آسانی بتوانید ویرایشگر قبلی وردپرس را فعال نموده و از آن استفاده کنید، بطور پیش‌فرض این ویرایشگر کلیه تنظیمات مربوط به ویرایشگر گوتنبرگ را پنهان می‌کند اما آن را از بین نمی‌برد. این افزونه دارای امکانات بسیار کاربردی از جمله امکان فعال کردن این ویرایشگر توسط مدیر سایت برای کلیه کاربران و امکان اجازه تغییر ویرایشگر به کاربران را فراهم می‌کند، همچنین ویرایشگر کلاسیک دارای فیلترهایی است که به سایر افزونه‌ها اجازه می‌دهد تنظیمات خود را تحت کنترل داشته و انتخاب ویرایشگر در هر نوشته و برگه را امکان‌پذیر کند.

افزونه Classic Editor را می‌توانید از مخزن وردپرس یا از انتهای همین مقاله به صورت کاملا رایگان دریافت نمایید، پس از نصب و فعالسازی افزونه، هیچگونه منوی جدیدی به پیشخوان وردپرس شما افزوده نخواهد شد، برای مشاهده تنظیمات این افزونه کافیست گزینه “نوشتن” را از منوی “تنظیمات” انتخاب کنید تا صفحه‌ای مانند تصویر زیر را مشاهده کنید.

تنظیمات افزونه Classic Editor
تنظیمات افزونه Classic Editor

گزینه “ویرایشگر پیش‌فرض برای همه کاربران” به طور پیشفرض بر روی حالت “Classic editor” قرار دارد، همچنین در صورت اجازه دادن به تغییر ویرایشگر توسط کاربر می‌توانید گزینه “اجازه تغییر ویرایشگر به کاربران” را بر روی حالت “بله” قرار دهید.

در صورت ایجاد تغییرات، تنظیمات را ذخیره نمایید.

ایجاد نوشته و برگه با ویرایشگر کلاسیک

با استفاده از افزونه Classic Editor به آسانی می‌توانید ویرایشگر گوتنبرگ را به ادیتور کلاسیک تغییر دهید، پس از انجام مراحل فوق کافیست یک نوشته یا برگه جدید ایجاد کنید تا مطابق تصویر زیر ادیتور کلاسیک را مشاهده کنید:

 ویرایشگر افزونه Classic Editor
ویرایشگر افزونه Classic Editor

همان‌طور که در تصویر فوق مشاهده می‌کنید در سمت چپ صفحه گزینه‌ای به نام “تعویض به ویرایشگر بلوکی” وجود دارد که با کلیک بر روی آن می‌توانید ویرایشگر خود را به ویرایشگر بلوک یا همان ادیتور گوتنبرگ تغییر دهید.

پس از انتشار برگه یا نوشته‌ تغییری که در آن‌ها ایجاد می‌شود این است که پس از ایجاد پست‌ها با ادیتور کلاسیک وردپرس، جلوی هر برگه یا نوشته مشخص می‌کند که با کدام ویرایشگر این نوشته ایجاد شده است.

 پست ساخته شده با افزونه Classic Editor
پست ساخته شده با افزونه Classic Editor

از این طریق شما می‌توانید به راحتی هر دو ویرایشگر را روی وردپرس خود داشته باشید و در صورت نیاز هر کدام را که خواستید فعال کرده و از آن استفاده کنید، گاهی مواقع ممکن است به دلیل ساخت بلوک‌های محتوایی مجبور شوید از گوتنبرگ استفاده کنید؛ پس این تعویض هویت در ویرایشگرها گزینه بسیار کاربردیست که به انتخاب کاربر واگذار شده است.

تغییر ادیتور گوتنبرگ به کلاسیک در وردپرس

پس از روی کار آمدن ادیتور گوتنبرگ به عنوان ویرایشگر پیشفرض؛ کاربران وردپرسی دچار مشکلات متعددی در نوشتن و مدیریت مطالب خود شدند، به همین منظور سیستم مدیریت محتوای وردپرس با افزونه Classic Editor امکان نصب ویرایشگر کلاسیک را نیز فراهم کرد که کاربران بتوانند در صورت نیاز از هر دو ادیتور استفاده کنند. در این مقاله نحوه تغییر ادیتور گوتنبرگ به کلاسیک در وردپرس را به شما آموزش دادیم، امیدواریم با مطالعه این مقاله بتوانید برای مدیریت و طراحی سایت وردپرسی خود ویرایشگر مناسب خود را انتخاب نمایید. شما می‌توانید سوالات و نظرات خود را از بخش دیدگاه‌ها با ما مطرح کنید؛ همچنین اگر محتوای امروز همیار وردپرس برایتان مفید بود، خوشحال می‌شویم آن را با دوستان خود در شبکه‌های اجتماعی به اشتراک بگذارید.

دانلود افزونه Classic Editor

صفحه افزونه
آیا این مقاله برای شما مفید بود؟
تقریبا
خیر

اگر می‌خواهید از آخرین و محبوب‌ترین مقالات ما در ایمیل خود مطلع شوید، همین الان ایمیل خود را در کادر زیر وارد کنید:

تعداد علاقه‌مندانی که تاکنون عضو خبرنامه ما شده‌اند:

428,912 نفر

دیدگاهتان را بنویسید

ارسال دیدگاه به معنی این است که شما ابتدا قوانین ارسال دیدگاه را مطالعه کرده‌اید و با آن موافق هستید.

دیدگاه‌های این نوشته جدید ترین ها شاخص

  1. 5 ماه عضو همیار وردپرس

    عرض سلام و وقت بخیر
    ببخشید من ویرایشگر کلاسیک رو فعال کردن اما فقط خط اولش برای بنده فعال هستش و خط دومش موجود نیست .
    یعنی امکان تغییر رنگ نوشته و خط کشیدن زیر محتوا برای من وجود نداره
    ممنون میشم راهنمایی بفرمایید

    • 4 سال عضو همیار وردپرس

      سلام
      باید برای فعال کردن اون بخش افزونه Advanced Editor Tools رو نصب کنید.

  2. 3 سال عضو همیار وردپرس

    سلام من مشکل php.ini دارم حتی max file size هم نصب کردم اما موقع نصب افزونه ها ایراد میگیره

    • 8 سال عضو همیار وردپرس

      سلام
      این موضوع رو با پشتیبانی هاست در میون بگذارید. احتمالا مشکل از نسخه پی اچ پی هستش